I am younger than 18, can I use Woolsocks?

We would like to inform you that financial regulations require that you must at least 18 years old to use Woolsocks.

Additionally, you need to have a valid email address before you can start using the app.

Other articles you might find interesting are:
What personal data do I need to submit to use Woolsocks?
Why am I not able to start using Woolsocks?

If you need further assistance, please click this link to send us a request.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section